May I help you?

Find out how much you can save.

Another security vulnerability on android device integrated in its own hardware

2016-05-10

Its time to upgrade your device software for protecting your device from a critical vulnerability which is integrated on the hardware itself. This vulnerability affects on android smartphone with version 4.3 or earlier where the software packeges are maintailed by the company Qualcomm, a renowned mobile chipmaker.

The issue is first discovered on the year 2011. In that year, Qualcomm introduce a new set of API to manage networking for Android Open Source Project. To provide the additional functionality for networking on the smartphone Qualcomm modifies the netd demon.

The hacker can exploit this vulnerability to gain physical access to your device or download other malicious content to hack your device.

The newer device are installed with patch for this vulnerability. So it better to upgrade your device to latest android version ( higher than 4.3 ) or get a new device.